Billing API and Payment Gateway Update
Incident Report for Maksekeskus.ee
Resolved
Updates installed successfully.
Posted almost 4 years ago. Aug 05, 2014 - 00:23 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted almost 4 years ago. Aug 05, 2014 - 00:22 EEST