Maksekeskus card form errors
Incident Report for Maksekeskus.ee
Resolved
Card form errors bug has been resolved
Posted 6 months ago. Jan 19, 2018 - 09:06 EET
Investigating
We have experienced errors with the card payments form since 5PM yesterday. We are working on the fix. Recurring payments have not been affected.
Posted 6 months ago. Jan 19, 2018 - 08:57 EET