Danske bank link under maintenance
Incident Report for Maksekeskus.ee
Resolved
This incident has been resolved.
Posted almost 4 years ago. Sep 11, 2014 - 15:32 EEST
Investigating
Danske banklink is currently under maintenance. Bank link will not be displayed in the Payment Gateway until maintenance is done.
Posted almost 4 years ago. Sep 11, 2014 - 14:18 EEST