Problems with Payment Gateway
Incident Report for Maksekeskus.ee
Resolved
Issues fixed, payment confirmations are processed normally again. We will try to update the faulty transaction statuses during the day and send an update to all affected merchants.
Posted about 4 years ago. Aug 19, 2014 - 12:03 EEST
Identified
Problems with returning to the merchant's shop.
Posted about 4 years ago. Aug 19, 2014 - 09:37 EEST