Transaction notification delay
Incident Report for Maksekeskus.ee
Resolved
This incident has been resolved.
Posted over 2 years ago. Jan 19, 2016 - 16:58 EET
Investigating
We discovered a delay in our transaction status async notifications (e-mail & http) this morning. The problem started at 00:00 and was resolved @12:25. We are investigating cause and extent of the problem.

We apologise for any inconveniences caused.
Posted over 2 years ago. Jan 18, 2016 - 16:04 EET