Danske Bank banklink payments not working properly
Incident Report for Maksekeskus.ee
Resolved
Danske Bank banklink payments have been restored. We are keeping a close eye on Danske payments for potential kickbacks.
Posted about 4 years ago. Aug 18, 2014 - 13:04 EEST
Identified
Issue has been identified and our development team is working hard to deliver a fix asap.
Posted about 4 years ago. Aug 12, 2014 - 18:33 EEST
Update
Joint investigation on-going with Danske Bank.
Posted about 4 years ago. Aug 12, 2014 - 11:53 EEST
Investigating
We are currently investigating this issue.
Posted about 4 years ago. Aug 12, 2014 - 09:59 EEST